Corrupted Mailbox in exchange 2010

  • June 16, 2012
  • by Hemang Shah

Table of Contents

No headings were found on this page.

Hello all,

It has been a really long time since I’ve posted a blog, but I’m going to work on it.

As I was working in an exchange environment, I was asked, how can I fix a corrupted mailbox?

The error they got was:

WARNING: The object domain.local/_Domain/Users/Administrator has been corrupted, and it’s in an inconsistent state. The

following validation errors happened:

WARNING: Database is mandatory on UserMailbox.

WARNING: Database is mandatory on UserMailbox.

This happens when some of the AD attributes on the user are missing.

Viewing mailboxes in EMC or EMS does not list the Administrator, creating a new mailbox for existing user won’t list Administrator as exchange thinks it has a mailbox already.

This can be resolved by using disable-mailbox command in Exchange Management Shell

Now you’ll be able to create the mailbox either in EMC or EMS.

When you populate users to create mailbox for, Administrator would be visible now:

Until later.

Thanks

Author: Hemang Shah

CEO, Logic V

As the CEO of Logic V Inc., Hemang Shah is responsible for running all facets of the business. Hemang is an accomplished IT executive with over 10 years experience in the IT industry.

Before founding Logic V Inc., Hemang has worked as Microsoft Practices Lead at Long View Systems, prior to that he was a Senior IT Infrastructure Consultant at Calgary based Compugen. Hemang also worked as Technical Accounts Manager at Microsoft.

Hemang hold’s Microsoft Certified Solutions Expert (MCSE) certificate. Hemang has been helping small and medium business clients to attain their IT infrastructure goals for over a decade.

Logic V Inc. was founded with the goal of bringing reliable technology management and advanced technologies to small and medium businesses.